要求 libbrotlienc.so.1()(64bit)が出たときの対処法

IUSリポジトリでApacheを使用していると、アップデートするときにエラーとなることがあります。
その対処法となります。

brotliという圧縮が対応?

要求 libbrotlienc.so.1()(64bit)

brotliという圧縮形式があり、iusのApacheはそのパッケージがないよという事でエラーをだしているみたいです。

対処方法

必要なパッケージをインストールします

wget http://download-ib01.fedoraproject.org/pub/epel/7/x86_64/Packages/b/brotli-1.0.7-5.el7.x86_64.rpm

rpm -Uvh brotli-1.0.7-5.el7.x86_64.rpm

これでアップデートが上手くいくと思います。もしApacheを一度消してしまったというかたは

yum install httpd --disablerepo=base --disablerepo=updates --enablerepo=ius

でインストールできると思います。

個人支援・寄付について

サイトラボでは環境構築スクリプトの開発などのため、現在個人支援・寄付を受けております。ご協力いただける方はお願いいたします。当サイトではkyashというサービスをつかっております。